Veeam Backup for Microsoft 365 Job Failures - YOW/Ottawa

Incident Report for Opti9 Technologies Status Page

Resolved

This issue has been resolved and all Veeam Backup for Microsoft 365 Job's are now succeeding.

We apologize for any inconvenience this may have caused.
Posted Mar 18, 2026 - 15:52 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Feb 18, 2026 - 17:29 EST

Identified

A subset of jobs are not running as expected, we are working alongside the vendor to resolve the issue.
Posted Feb 13, 2026 - 13:12 EST
This incident affected: YOW - Backup (Veeam Backup for Microsoft 365 - office365).