Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Sep 16, 2026 - 21:30 EDT
Scheduled
As part of our ongoing commitment to maintaining a secure and reliable environment, we will be performing urgent firewall maintenance. MikroTik has identified a critical security vulnerability in RouterOS and has released software updates containing the required security fixes across all supported release channels. While most configurations are not at risk, upgrading the affected devices is highly recommended.
RouterOS will be upgraded to the most recent stable versions: RouterOS 6.49.21
Details/Impact/Risks: - Minimal service disruption is anticipated. - A brief interruption to network connectivity may occur while the MikroTik devices reboot and complete the RouterOS upgrade. - During the maintenance window, we will perform the upgrade, verify device’s health, and validate connectivity and critical network services after completion.
Our team has taken all necessary precautions to minimize service impact and downtime. We appreciate your understanding and patience as we complete these important infrastructure upgrades
Posted Sep 16, 2026 - 16:41 EDT
This scheduled maintenance affected: GSC - Backup (Veeam Service Provider Console - gsc2-acw, Veeam Service Provider Console - gsc3-acw, Veeam Cloud Connect Backup - pub1-gsc2-cgb, Veeam Cloud Connect Replication - pub1-gsc2-cgr, Veeam Backup for Microsoft 365 - gsc3-m-portal, Veeam Backup for Microsoft 365 - portal-m-gsc, Veeam Cloud Connect Backup - pub1-gsc3-cgb, Veeam Cloud Connect Backup - pub2-gsc3-cgb, Veeam Cloud Connect Replication - pub1-gsc3-cgr, Veeam Backup for Dedicated Private Cloud - GSC, Veeam Backup for Cloud Director - GSC, Zerto - GSC), MTL - Backup (Veeam Cloud Connect Backup - pub1-mtl2-cgb, Veeam Cloud Connect Backup - pub2-mtl2-cgb, Veeam Cloud Connect Replication - pub1-mtl2-cgr, Veeam Service Provider Console - mtl2-acw, Veeam Backup for Cloud Director - MTL), and SG - Backup (Veeam Service Provider Console - sg-acw, Veeam Cloud Connect Backup - pub1-sg-cgb, Veeam Cloud Connect Backup - pub2-sg-cgb, Veeam Cloud Connect Replication - pub1-sg-cgr, Veeam Backup for Cloud Director - SG).