Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 09, 2026 - 16:00 EDT
Scheduled
We will be performing firmware updates on one of our storage area networks (SANs) to maintain system performance and reliability. This SAN is designed with redundant controllers and connections, allowing maintenance to be completed sequentially. Because of this, we do not expect any impact to services during this work. If you experience any unexpected issues, please don’t hesitate to reach out to our support team.
Posted Jun 05, 2026 - 09:23 EDT
This scheduled maintenance affected: LON - Cloud (Storage - LON).