Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Sep 16, 2026 - 11:00 EDT
Update
We will be undergoing scheduled maintenance during this time.
Posted Sep 14, 2026 - 13:37 EDT
Scheduled
As part of our ongoing commitment to maintaining a secure and reliable environment, we will be performing scheduled reboots of some of our backup infrastructure servers.
Details / Impact / Risks: - The backup servers included in this maintenance will be temporarily offline during the reboots. - The maintenance will be performed in a controlled manner, with appropriate pre- and post-maintenance validation checks. - Some service interruption is anticipated as a result of this maintenance.
Our team has taken all necessary precautions to minimize risk and ensure the maintenance is completed safely. We appreciate your understanding and patience as we complete these important infrastructure reboots.
Posted Sep 14, 2026 - 13:31 EDT
This scheduled maintenance affected: YOW - Backup (Veeam Backup for Microsoft 365 - yow02-m).