Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Aug 29, 2026 - 21:00 EDT
Scheduled
Systems may experience a brief, minor interruption to network connectivity during the maintenance window as switching is upgraded within the YOW data center fabric. Service should automatically recover within moments as the network relearns forwarding paths on the redundant infrastructure.
Posted Aug 27, 2026 - 15:04 EDT
This scheduled maintenance affected: YOW - Backup (Veeam Cloud Connect - hostedbizz, Veeam Cloud Connect - yow01-b, Veeam Cloud Connect - yow02-b, Veeam Cloud Connect - yow03-b, Veeam Service Provider Console - console, Veeam Backup for Microsoft 365 - office365, Veeam Backup for Microsoft 365 - yow01-m, Veeam Backup for Microsoft 365 - yow02-m, Veeam Backup for Microsoft 365 - yow03-m, Veeam Backup for Microsoft 365 - yow04-m, HBizzVault, HBizzSync, Veeam Backup for Cloud Director - YOW) and YOW - Cloud (Compute - YOW, Network Core - YOW, Storage - YOW, Facilities - Power/Cooling - YOW, Cloud Director - YOW, Horizon View - YOW, Internet Services - YOW, Virtuozzo - YOW).