Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Apr 15, 2026 - 23:01 EDT
Scheduled
As part of our ongoing commitment to maintaining a secure and up-to-date environment, we will be performing a scheduled operating system upgrade on our edge routers. These enterprise-grade routers are configured with redundancy to ensure high availability.
As a result, we anticipate only brief, intermittent service disruptions as traffic is seamlessly redirected between devices during the upgrade process. The maintenance activity is expected to be completed within approximately one hour.
Posted Apr 10, 2026 - 11:04 EDT
This scheduled maintenance affected: CHI - Cloud (Compute - CHI, Network Core - CHI, Storage - CHI, Facilities - Power/Cooling - CHI, Internet Services - CHI) and CHI - Backup (Zerto - CHI, Veeam Cloud Connect Backup - pub1-chi-cgb, Veeam Cloud Connect Replication - pub1-chi-cgr, Veeam Service Provider Console - chi-veeam-acw, Veeam Backup for Cloud Director - CHI).