Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 07, 2026 - 11:00 EST
Scheduled
During the maintenance window, clients may observe brief periods of high storage latency due to controller failover. There is no expected impact to workloads, given that controller redundancy is in place.
Posted Mar 03, 2026 - 16:35 EST
This scheduled maintenance affected: GSC - Cloud (Storage - GSC).